Tip : Troubleshooting Random Kernel Panics

Most of the time , I get e-mails from folks on how to troubleshoot a kernel panic which occurs all of a sudden. I am not talking about pre-boot ones but the kernel panics which occurs in the middle of OSX. You’ll get the fancy Please reboot your PC screen. But that does not help in troubleshooting or find the root problem – especially if you want to troubleshoot sleep related problem. I’m talking about OSX insomnia !

To do this , its very simple – all you have to do is

1. (Re)Boot your PC

2. When you’re in the Chameleon menu (aka when count down starts) hit Tab once

3. Then type (without quotes) “debug=0x144” or “debug=0x14e” . This will give you a traceback which is useful for you on understanding what is causing the kernel problem. Once you’ve found the cause you may then seek in forums on how to rectify it

20 thoughts on “Tip : Troubleshooting Random Kernel Panics”

  1. Pingback: Sergey
  2. How do I fix it now ?, because I cannot get any further than this screen, I tried reinstalling from USB again, but I am getting same message again.

  3. Ok, i’ll take your no response as a no, would have been nice if you had been bothered to acknowledge me though rather than being completely ignorant and ignoring my question completly.

    thanks for nothing

  4. Chris , just check your e-mail. I’ve replied to you. I need some information . I am not giving any excuses. Plus I’ll be needing a lot of details. If you need urgent help just e-mail !

  5. i am geting the same thing kernal panic. i have a amd turiton dual core and i have a ati radeon 1200 laptop.

  6. Hey thanks for the blog. I ran into trouble while attempting to install. The EFI disk booted just fine. I was able to then get into the install, but everytime it gets to the end failing saying it couldn’t restart from boot disk. Upon reboot and into the EFI cd and then onto the HD I get a CPU halted with unable to load kext.appleIO…. I couldn’t get it all as the system shuts down. I have a vanilla ga-ex58-ud5 with a nVidia GT9400 video. I have nothing else attached. Any help will be welcome. I have been struggling with this for quite a while now and need help.

    Cheers

  7. hi pradeesh,
    im also having the same problem….
    like this..http://img31.imageshack.us/img31/3743/dsc00174ha.jpg

    this is not my screenshot….
    but it appears like this …i installed every thing ….and its works fine….when i try to import video into Finalcutpro 7 …1st time fcp closed..2nd time this error appears and system hanged up…..?

    any suggesion…?

    Pradeesh ,im waiting for your reply…..([email protected])

  8. Come on guys, the boys are busy enough and nice enough to create and post this so you can run OSX so easily, think of the 1000’s of questions they get, do a little research on your own, the answers are out there!!

    They owe you nothing and I’ll bet very few have donated to their cause….

  9. Acpi table not found in snow leopard, my leopard pc does not boot, just when i have the empire efi cd inside, i have asus p5b, 3 ddr2 ram, nvidia geforce 8600 gt, what can i do?

  10. pradeesh,
    I had posted on another part of the site about a problem i was having. i have the picture of the error. it says something about the Kernel extensoins in back trace (with dependencies)
    sskk..ttrriiaaxxiiss..kkeexxtt..SSlleeeeppEEnnaabblleerr((11..00..00))@@00xx blah blah blah. The whole thing looks like its studdering.
    Any suggestions?

  11. i m not able to install os x lion in my dell inspiron 1545 it gives error like this sam multimedia read write failed

  12. monster, the problem is clearly displayed: “Secondary PCI IDE channel is disabled”. The problem is your mobo has only 1 IDE-PATA bus, so in order for OS X to work I guess you’ll need to enter into BIO SETUP and change SATA mode to IDE.

    I hope this will work.

Leave a Reply

Your email address will not be published. Required fields are marked *

CommentLuv badge